Back What's new

Anybody ever "lose" their capture data?

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


Spent a long night not long ago and grabbed some great data from M45.....now, after having some spare time to start playing with it.. it is like "Where is Waldo". Looked on my external drives and the capture drive on my image processing machine... and can't find hide nor hair of them. I think I may have inadvertently deleted them instead of some "trash" data I had from a similar capture of M45 that the exposure time and gain were not enough. :cry:

Hopefully it will be a decent night tonight as I'll set back up again and once more run a set of captures... this time I may go ahead and try then in a mosaic format.

I've now got set up an external USB drive enclosure that I can insert and remove drives from... so will start cataloguing and copying the data to them from the other portable hard drive... and NOT delete anything until I've at least run a base stack of the images.
 

OhNo

Founding Member
Messages
327
Reaction score
136
Location
Saskatchewan, Canada
As I use the same breed of Capture/Control OS as you I know what you did. But before I tell you where your missing data is I want you to read this: Use the KISS Method until you are intimately familiar with the OS. Forget the external drive, or USB crap. A 64GB Micro SD card will give you enough storage for a months worth if imaging...

Your data is in limbo on your SD card somewhere. What happened is the files destination has changed. You are running v1.7.2. Guess what. It don't work. Download v1.7.1, flash a Micro SD card with the old (and it isn't all that old) BUT it is STABLE. The geniuses at INDI haven't got the file structure figured out to store anything anywhere BUT on the SD card.

On the camera control screen find the little box that opens the directory tree. (see attached image Directory Tree switch Circled in red) Manipulate it to see where your images are. Now here is another complaint, the are using some new directory structure that is terrible.
 

Attachments

  • Cam PS.jpg
    Cam PS.jpg
    206.2 KB · Views: 8

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


No, they were actually there, as I manually copied them over from my SD card (in the Pictures/ in flat bias and light folders) using the file manager to my /media/StellarMate/CapStor location of the attached 4TB portable HD, and THEN moved them over to the capture machine. I simply remove them from the portable when done copying them over. My issue was I actually deleted the 240s/101 gain captures instead of the 60s/180 gain captures. Think it was more being tired than anything. It's one of the reasons that I'm going to start having INDI append the date/session/filter info onto the file name instead of simply the object (like M45).

Screen Shot 2022-09-22 at 8.19.30 PM.png


Both the RPi's I have are equipped with 256GB cards...so space isn't the issue... it's simply easier for me to mass move from the SD card (with it's slower through-put) to a USB 3 WD external hard drive.
It was more not being familiar with the ability to append that data to the file names... and since the 60 second captures were trash, but all were titled M45 I deleted the wrong ones. And due to the sizes, they didn't go to the trash can, they simply went to the bit bucket.

What I generally do (and have modified the fresh install again of Stellarmate I had to do to confirm to Jasem that if I changed my VNC password on a fresh install the Stellarmate IOS app and the web interface would not connect to VNC) is define a set location under my /home/stellarmate directory named Captures so it doesn't get mixed in with any regular photos.. and it's easier to write a script up to run to copy those captures automatically over to the external hard drive when I attach it.

Screen Shot 2022-09-22 at 8.15.22 PM.png
 

OhNo

Founding Member
Messages
327
Reaction score
136
Location
Saskatchewan, Canada
Just wait until you use the Scheduler, especially for a Mosaic. You not only have to file the date in you have to instruct where to save the images AND file in the Schedule for the THIRD time......
 

OhNo

Founding Member
Messages
327
Reaction score
136
Location
Saskatchewan, Canada
BTW I transfer all by nightly data to my imaging computer from the RPi via ethernet connection. Takes maybe 10 seconds and it isn't third had by the time I process it.
 
Top