Back What's new

Stellar Mate New version out

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


Apparently the RPi sudo apt-get update then apt-get ugprade gets you the "cutting edge" of the lastest Indi and Kstars... and there ARE some changes. Decided to update while I was out playing with the scope... BIG mistake. Now it's not even controlling the mount, and the interfaces have changed noticeably. Once I get some time I will detail some of the changes, and what I had to set to get all my stuff back recognized.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


So far... every time I try to take an image capture with my ASI533MM Pro, Kstars restarts...so I can't get a good alignment since I need the camera to do so, therefore I can't fully align the mount so that Stellarmate can run the mount controls.

Warning... there are a LOT of changes to get your config to work.... I'm still finding more. Once I get the system figured out, I'll document what I found in this thread with pictures of what/where the new stuff is. Biggest change is now you have optical trains that you have to configure.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
LOL Beta testing. If it ain't broke....... :ROFLMAO: :ROFLMAO: :ROFLMAO:
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


LOL Beta testing. If it ain't broke....... :ROFLMAO: :ROFLMAO: :ROFLMAO:
They shouldn't be letting any "bleeding edge" **** out in the normal update stream.
I have confirmed that the mount (SynScan) HAS to be active before the camera can capture.. if it's not, KStars restarts every time. Once you finish your alignment on the mount, then the camera works. Which is messed up, because as I indicated, I use the camera to get a good alignment by doing a 0.2 second loop and then making my adjustments with the crosshairs showing.
Not only that... now not only do you have to set up your telescopes, but then you have to set up individual optical trains... and that INCLUDES for a guide scope.
I've got a new cable on order that bypasses the hand controller and plugs directly into the control box itself... I'm hoping that may bypass the stupidity of requiring the mount to be aligned before you can use in in Stellarmate.

Now another problem I'm having is with plate solving..... JNow detects the mount location correctly - but when going to plate solve it tells me I'm something like 500K arc seconds off from the star, which KStars had no issues with slewing to and it shows up in an image capture.

This definitely has been a wasted night.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


Only thing I have to say is... if you upgrade, have PLENTY of whiskey/bourbon handy.
I DO like some of the layout/positioning of some of the stuff.... once you get use to it it's a tad more streamlined.
But the problem is that if you are used to the old layout, you are going to be SORELY pressed.
 
Last edited:

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


I'm wondering if my "upgrade" corrupted something vital. I was able to finally get it to working somewhat early this morning and got some great captures of M81/M82. Then set up tonight and it went to pot again. Got so frustrated I decided to burn a new image of it to the SD card... but..... forgot to copy the captures I did this morning off before I did so... so that's 2 hours down tube.

But, the weird thing is, I have 2 RPi's. One is set up for my refractor, and the other for the NexStar. I do have definitions for both scopes in each though. The tracking that I never could get below the RA 4.x/DEC 3.x range last night (and it was a nice clear night) is doing MUCH better on this older install, and our sky is not as nice as it was last night.

Screen Shot 2022-10-02 at 9.46.01 PM.png


The new install is in the 11.x range for RA and 5.x range for DEC...with NO changers other than a card changeout on the RPI to the newer version.

Also, my plate solving issue may have been resolved by setting my binning for my camera at 1x1 instead of 2x2 that ships as a default. Once I did that, it almost immediately completed a successful plate solve.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


And now I can go back to 2x2 on the binning for the plate solving. Don't ask me what the difference was... but flipping to 1x1 then back seemed to resolve the plate solving issue.
And now I'm getting decent RA/DEC numbers out - not great but I realize the mount is borderline overloaded, and the viewing is not great tonight.

If you have time to take to mess with the changes in the upgrade, they seem to be worth it.

This is going to be one of the biggest issues for some, especially a new person just coming into it and barely familiar with KStars and its old setup. You now have to define optical trains for both your guide and your main scope (and any other scopes you may have).

Screen Shot 2022-10-03 at 2.37.05 AM.png
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


Bug for not being able to use the camera until the mount is connected has been fixed. I'm still getting some KStars stopping... but haven't tracked it down to exactly why yet.
I did figure out that you have to a location in KStars before the plate solving works on my mount. I'm hoping when the EQMOD cable arrives that may be resolved.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
I suspect it is a power supply issue.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


I suspect it is a power supply issue.
it was apparently a bug in KStars. The update fixed the camera issue.. but you STILL have to get an 1-3 star alignment before you can even think about a Polar alignment... and every time I tried one of those KStars restarted.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
Yeah, do a star alignment then do a PA...... A lot of ppl who have to tear down/set up every night will use something to mark where each leg of the tripod goes.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


I'm beginning to wish now I'd gotten an Intel NUC and rolled my own setup with Ubuntu and KStars/INDI on it.
Did another of the "IOS App" updates... and now I have all the KStars/Indi/Ekos stuff missing along with a LOT of support files. So, downloaded 1.7.3 directly from SM and am now in the process, once more, of installing it again and having to go through all the config hassles once more.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
There seems to be two types of people in the AP game. Those that take images and those that write software to run gear to control/capture images. While the imaging types have pushed the limit of possibility of earth bound space photography, the software types are re-creating the wheel over and over again.

A lot of software seem to be easiest to figure out if you've grown along with it. Coming late to the party leaves you asking questions and wondering why you do it this way..... StellarMate is a prime example of this. I started out with v1.5.? (didn't save a copy of the original) and soon they had v1.5.8. v1.5.8 was a rock solid program. Then the had v1.6.0 a dud. On to v1.6.2 stable but the benefits over v1.5.8 were few. v1.7.0 was short lived until v1.7.1 arrived. The improvement to it were significant AND beneficial. This far v1.7.2 has proved a step backwards IMO.

It appears the "latest and greatest" to be a crap shoot with SM. I wish he could find someone who has a mind for updating the arrangement of the screens and the overlap of control between the individual screens.

I know nothing about writing computer software, but I think I am all right in figuring out how to get it working with the gear I have. This opens up another issue, and by no stretch of the imagination am I NOT defending software designers for releasing software that doesn't work, but the sheer number possible gear combinations is a huge task for a software programmer to consider.

I have a friend who wrote software for one on the Major companies in the world. He still gets royalties to this day. We were discussing some of the SM issues. He had Jasem's personal e-mail and had offered beneficial solution to a few problems. A major one came up that effected his Mac that I didn't have with the Windoz computer. All of the sudden Jasem doesn't respond any more.....

It's possibly time to decide what the ultimate goal in the HOBBY is.
 
Last edited:

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
In addition, if you want to take images and have something to show for your effort I'd find v1.5.8 and run it for a while. Put some picture together and enjoy....
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
NINA became a thing right at the tail end of my DSLR days. I'm sure it has come leaps and bounds since. I opted to give SGP a try, one box not clicked just right...crickets. Got the ASIAir Pro, the program was like going from a Ferrari back to a model "A".
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


All of the sudden Jasem doesn't respond any more.....
I've got a ticket open over on SM's site still that he just simply quit communicating on after I explained to him that I HAD followed their instructions on how to change the VNC password, and their phone/tablet app and the web interface to SM would NOT connect to the VNC server using OpenVNC that they use on both the web interface and the mobile app. Change the password back to what it ships as and it works fine, so that tells me that they are most likely hard-coding the default password into their install and have not configured OpenVNC client to prompt for a password. Turns out another person over on the INDI forum has had the same problem. It appears he simply has thrown his hands up about it, but I plan on updating the ticket and reference back the INDI forum post.

In 1.7.3 they have gone to "Optical trains". I like the idea, but it was quite a bit to "spring" on someone doing an upgrade. Especially when you consider the primary scope that did transfer over could not be edited nor could it be deleted when I did the first upgrade to 1.7.3 (which also ended up having to re-install again to 1.7.2).

Screen Shot 2022-10-10 at 8.49.58 PM.png

As you can see in this image... it shows "Sample" scope/lens. I had to go back and define the scope settings in the Telescope & Lens button. This is on a fresh install, and it should have prompted for that data when first setting up.

It's possibly time to decide what the ultimate goal in the HOBBY is.
For me, it's a little of both, since I come out of almost 2 decades in IT. We don't have great sky tonight so I didn't go set up... we've had moderate low level clouds but a LOT of high level clouds/haze for the last several days. The last few sunsets have been a deep dark orange sky and when you can see the stars, you realize where the phrase "twinkle twinkle little star" comes from, which from my understanding is upper level instability which negatively affects extended exposure captures.
 
Last edited:

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


A lot of ppl who have to tear down/set up every night will use something to mark where each leg of the tripod goes
Canary yellow paint is easy to see in the day... not so easy under a red light. Ask me how I know! :whistle:
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
When you mentioned the new version I headed over and downloaded it. The optical train thing sucks. It decided my 120MM Mini and guide scope were my main imaging scope. A hour of messin' with it and still could convince it otherwise.

BUT the biggest issue 1.7.2 and 1.7.3 suffer from is in both versions since 1.7.1 you can't open KStars from the top banner without closing EKOS. In v1.7.1 you can go back and forth all night from the top header. As I said if you can find v1.5.8 flash it to a Micro SD card, it is rock solid and gets you putting the expensive gear you bought for thousands and are confused by a $49 dollar OS.

This hobby is frustrating enough without having to second guess what some software guy that sits around all day growing pimps on his nether butt churning out the latest greatest to keep up with the Jones'. He ought to personally use it before it is released. Saying "it worked fine in the Sim" ain't what it works like in the REAL world.

Stan mentioned NINA. The reason I opted to go another way way the scuttlebutt about ASCOM being done away with. RPi/INDI has a lot of applications, ASCOM may be getting close to oblivion.
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


Stan mentioned NINA. The reason I opted to go another way way the scuttlebutt about ASCOM being done away with. RPi/INDI has a lot of applications, ASCOM may be getting close to oblivion.
One of the nice things about a NUC is that since it's Intel based and will run any of the normal 64bit Linux distro's, you can roll your own KStars/Indi/Ekos load on a supported platform. It also can use actual NVMe drives. The REAL downfall is the price. You can get 3-4 RPi's for what one decent NUC cost.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
You lost me at..... :ROFLMAO:

KISS theory makes the hobby more enjoyable....
 

Stan

Founding Member
Messages
38
Reaction score
27
Too many systems use ASCOM for it to go away, the scuttlebutt is probably wishful thinking by other system designers
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
I had regular issues with ASCOM drivers. Seems there was always a new up-date.....
 

Tracy

Dark Sky Lover
Founder
Messages
415
Reaction score
62
Location
Texas
Telescopes

William Optics 103mm
Celestron NexStar 8SE


I REALLY wish Jasem and company would better test their updates out before they release them. Updated to the latest last night hoping it might solve some focusing issues... and now, VNC becomes totally unresponsive for minutes at a time. He was apparently having a problem with the app becoming unreponsive and made some "changes"... which apparently have affected VNC also. Nice night to try to do some captures before the storms move back in and I can't do squat.
I'm not really happy with them for a "paid" software, and I don't seem to be able to get a response to ticket issues I enter.
 

OhNo

Founding Member
Messages
326
Reaction score
136
Location
Saskatchewan, Canada
I told you. Find v1.7.1 and go......
 
Top